※上記の広告は60日以上更新のないWIKIに表示されています。更新することで広告が下部へ移動します。

「なでしこプログラム板」の編集履歴(バックアップ)一覧はこちら

なでしこプログラム板」の最新版変更点

追加された行はこの色になります。

削除された行はこの色になります。

 *プログラムのソースを置く広場 [#x5b4a6fb]
 ----
 
 今のなでしこは、version1.5324 (2009/12/06)
 ----
 #memo(t)
 #memo()
 #memo()
 #memo()
 #memo(#ステータスバー\nF=0.5\nF2=0\n下バーとは、ステータスバー。\n\nそのクリックした時は〜\n ダイアログ数値変換はオン\n ダイアログIMEは「IMEオフ」\n 「更新間隔は?」と尋ねる。\n もし、それが「」でなければ\n  時計更新の間隔はそれ\n 違えば、\n  待機。\n設定とはボタン\nそのクリックした時は〜\n ダイアログ数値変換はオン\n ダイアログIMEは「IMEオフ」\n 「更新間隔は?」と尋ねる。\n もし、それが「」でなければ\n  時計更新の間隔はそれ\n 違えば、\n  待機。\n\n#情報ステータスバー\n時計更新とはタイマー\nこれについて\n 間隔はF\n 時満ちた時は〜\n  下バーは「{OS} {OSバージョン}|{今日}|{今}|CPU:{CPU使用率取得}% メモリ:{メモリ使用率取得}%」\n  母艦=「{下バーのテキスト}」\n 開始\n\n)
 #memo(#画像作成のためのツール  メガ\n母艦のファイルドロップ許可はオン\n母艦のファイルドロップした時は〜\n 母艦のドロップファイルを反復    \n 対象を読む\n それをBASE64エンコードして900で行揃えしてメモ記入\n)
 #memo(#Kiuu0.12test3をすこし変えた版(11/6)   byメガ\n!母艦設計=「母艦の可視はオフ」\n#フォント選択処理\nもし、OSバージョン≧6ならば、\n 文字書体は「メイリオ」\n\n母艦のタイトルは「KIUU」\n母艦の閉じた時は〜設定保存\nWEBブラウザとはブラウザ\nWEBブラウザのレイアウトは「全体」\nその完了した時は〜 \n 母艦のタイトルは「{WEBブラウザのタイトル}  KIUU」\n\n「,親1,メニュー \n-,印刷,ページの印刷(&I),,,WEBブラウザの印刷プレビュー\n-,Li,検索エンジン(&L)\n--,子子1,Google(&G),,,WEBブラウザのURLは『http://www.google.co.jp/』\n--,子子2,Yahoo(&Y),,,WEBブラウザのURLは『http://www.yahoo.co.jp/』\n--,子子3,Bing(&B),,,WEBブラウザのURLは『http://www.bing.com/』\n--,子子4,livedoor,,,WEBブラウザのURLは『http://www.livedoor.com/』\n--,子子5,楽天市場(&R),,,WEBブラウザのURLは『http://www.rakuten.co.jp/』\n--,子子6,Goo,,,WEBブラウザのURLは『http://www.goo.ne.jp/』\n--,子子7,infoseek,,,WEBブラウザのURLは『http://www.infoseek.co.jp/』\n-,-,,,,\n-,Li2,kiuu関係ページ\n--,子子8,ダウンロードぺージ,,,WEBブラウザのURLは『http://www15.atpages.jp/kiuuserver1/kiuu/index2.html』\n--,子子9,作者ページ,,,WEBブラウザのURLは『http://www15.atpages.jp/kiuuserver1/k.k/index.html』\n--,子子10,kiuuWiKi,,,WEBブラウザのURLは『http://www15.atpages.jp/kiuuserver1/wiki/』\n-,-,,,,\n-,Li3,ツール\n--,子子11,OS調べ,,,k\n-,-,,,,\n-,Li4,kiuuバージョン情報,,,バージョン情報\n-,-,,,,\n-,閉じる,終了(&S),,,母艦を閉じる\n,SET,設定,,,設定」をメニュー一括作成\n\nバーとはパネル\nこれについて\n レイアウトは「上」\n Hは30\n 背景色はウィンドウ背景色\n\nbaとは画像ボタン\nこれについて\n テキストは「」\n Yは-1\n Xは5\n Hは30\n Wは30\n 画像は「{母艦パス}\kiuu_dll\1.png」\n 親部品はバー\n クリックした時は〜WEBブラウザの戻る\n ヒントは「戻る」\n フラットはオン\n\nneとは画像ボタン\nこれについて\n テキストは「」\n Yは-1\n Xは40\n Hは30\n Wは30\n 画像は「{母艦パス}\kiuu_dll\2.png」\n 親部品はバー\n クリックした時は〜WEBブラウザの進む\n ヒントは「進む」\n フラットはオン\n\nもし、(「{母艦パス}\kiuu_dll\4.png」の存在=1)ならば、\n koshinとは画像ボタン\n これについて\n  テキストは「」\n  Yは-1\n  Xは85\n  Hは30\n  Wは30\n  画像は「{母艦パス}\kiuu_dll\4.png」\n  親部品はバー\n  クリックした時は〜WEBブラウザの更新\n  ヒントは「更新」\n  フラットはオン\n\nアドバーとはエディタ\nこれについて\n Yは0\n Xは125\n Wは母艦のW-180\n ヒントは「URLを表示します」\n キー押した時は〜\n  もし、アドバーの押された仮想キーが「13」ならばWEBブラウザのURLはアドバーのテキスト\n\naaとは画像ボタン\nこれについて\n テキストは「」\n Yは-2\n Xは125+アドバーのW\n Hは30\n Wは30\n 画像は「{母艦パス}\kiuu_dll\3.png」\n 親部品はバー\n クリックした時は〜WEBブラウザのURLはアドバーのテキスト\n ヒントは「指定のURLに飛びます」\n フラットはオン\n\n#母艦サイズ変更時\n母艦のサイズ変更した時は〜\n  アドバーのW=母艦のW-180\n  aaのX=125+アドバーのW\n\n#ステータスバー\n\n下バーとはステータスバー\n時計更新とはタイマー\nこれについて\n 間隔は1\n 時満ちた時は〜\n  下バーは「{今日} {今} CPU:{CPU使用率取得}% メモリ:{メモリ使用率取得}% {WEBブラウザのURL}」\n 開始\n\n#設定フォーム\n設定Fとはフォーム\nこれについて\n 可視はオフ\n W=400。H=300。\n スタイルは「枠固定」\n設定Fを最前面\n基本設定とはグループボックス\nこれについて\n 親部品は設定F\n X=10\n Y=10\n W=360\n H=220\n 文字サイズは「12」\n\n間隔Lとはラベル\nこれについて\n 親部品は基本設定\n テキストは「更新間隔(ms):」\n X=10\n Y=33\n\n間隔EDとはスピンエディタ\nこれについて\n 親部品は基本設定\n X=100\n Y=30\n テキストは「1000」\n 最小値は10\n 最大値は5000\n\nOKBとはボタン\nこれについて\n 親部品は設定F\n X=220\n Y=240\n テキストは「OK」\n そのクリックした時は〜\n  時計更新の間隔は「{間隔ED/1000}」\n  設定Fを閉じる。\n  \n\n#母艦表示\nもし、(「{母艦パス}setting.kiuu」の存在=1)ならば、\n 設定読込\n母艦の可視はオン  \n\n●設定\n 設定Fを中央移動。\n 設定Fの可視はオン。\n\n●設定読込\n 「setting.kiuu」のINI開いてSINIに代入。\n SINIで「設定」の「位置」をINI読んでBXYに代入。\n SINIで「設定」の「間隔」をINI読んでKANに代入。\n SINIのINI閉じる。\n 母艦の位置はBXY\n 時計更新の間隔は「{KAN/1000}」\n 間隔EDのテキストはKAN\n\n●設定保存\n 「setting.kiuu」のINI開いてSINIに代入。\n SINIで「設定」の「位置」に「{母艦の位置}」をINI書く。\n SINIで「設定」の「間隔」に「{間隔ED}」をINI書く。\n SINIのINI閉じる。\n\n*バージョン情報\n  「バージョン情報\n  v0.12テスト版3です」と言う。 \n*k\n 「{OS}  v{OSバージョン}」を言う。\n母艦の可視はオン)
 #memo(#お気に入り機能(試作2) すこし変更しました。 by メガ\nWEBブラウザとはブラウザ\nそのレイアウトは全体\nもし、「{母艦パス}favorite.txt」が存在でなければ、\n 「{母艦パス}favorite.txt」に「なでしこ公式ページ,http://nadesi.com\n」を保存。\n「,a,開く,,,しおり表示\n,b,削除,,,しおり削除」をメニュー一括作成\n●しおり表示\n ページ名称は空。\n ページURLは空。\n 「{母艦パス}favorite.txt」を開いて、反復\n  それを「,」で区切る。\n  それ¥0をページ名称に配列追加。\n  それ¥1をページURLに配列追加。\n ページ名称でリスト選択。\n もし、それが空ならば、戻る。\n ページ名称の0からそれを配列検索。\n WEBブラウザのURLは、ページURL¥それ\n●しおり削除\n ページ名称は空。\n ページURLは空。\n 「{母艦パス}favorite.txt」を開いて、文字に代入。\n 文字を改行で区切って、反復\n  それを「,」で区切る。\n  それ¥0をページ名称に配列追加。\n  それ¥1をページURLに配列追加。\n ページ名称でリスト選択。\n もし、それが空ならば、戻る。\n ページ名称の0からそれを配列検索。\n 文字のそれを配列削除。文字を「{母艦パス}favorite.txt」に保存。\n)
 #memo(#なでしこのバージョンを調べるやつです\n母艦=「なでしこversion調べ」\nナデシコバージョンをFに代入\nナデシコ最終更新日をF2に代入\n「このなでしこはversion{F}\nリリース日{F2}」を表示。)
 #memo(#にせコマンドプロントがコマンド実行というサンプル\n※【なでしこ実行モード】cnako\n「>hello」を継続表示\n「{改行}hello,word」を継続表示\n「{改行}>dir」を継続表示\n「{改行}\n               0 個のファイル                    0 バイト\n               0 個のディレクトリ  130,000,000,000 バイトの空き領域{改行}>」を継続表示\n待機。)
 #memo(#URLエンコードをもとに戻したやつです。いまは/しか出来ませんけどbyk.k\n「ああ」と尋ねる\nそれをURLエンコード\nそれをFに代入。\nもし、Fが「%2F」ならば、「/」とメモ記入。\n)
 #memo(#にせコマンドプロント\n※【なでしこ実行モード】cnako\n「>」を継続表示\n待機。)
 #memo()
 #memo(#megamemo0.0.2α  byメガ\n#メモ帳です。\nv=「0.0.2α」\n母艦は「MegaMemo{v}」\n「,aa,ファイル\naa,印刷,印刷,,,母艦印刷\naa,あああ,ファイルを開く,,,開く処理\naa,区切り2,-\naa,保存,名前をつけて保存,,,メモ保存\naa,終了,終わる,,,母艦を閉じる\n,bb,ヘルプ\nbb,bba,バージョン情報,,,バージョン」をメニュー一括作成\nmmとはメモ\nmmについて\n レイアウトは全体\n 文字サイズは13\n●メモ保存\n  「テキスト(*.txt)|*.txt」のmmのテキストで保存ファイル選択して保存パスに代入\n  もし、保存パスが「」でなければ、\n   mmを保存パスに保存\n●バージョン\n 「[MegaMemo]{~}{v}」と言う\n●開く処理\n ファイル選択。\n もし、それが空ならば終わる。    \n それを開いて内容に代入する。\n mmのテキストは内容\n)
 #memo
 #memo
 #memo
 #memo()
 #memo
 #memo
 #memo()
 #memo()
 #memo
 #memo